Slow response when loading Zapier pages.
Resolved·Degraded performance

This incident has been resolved.

Wed, Aug 31, 2022, 02:35 PM
(3 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Wed, Aug 31, 2022, 02:35 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Wed, Aug 31, 2022, 12:42 PM(1 hour earlier)

Investigating

We are currently experiencing an incident where some pages can't load, including and not limited to /Zaps page. Our Engineering team is currently investigating the issue, and we will keep you posted on the progress.

We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything: https://zapier.com/app/get-help.

Wed, Aug 31, 2022, 12:20 PM(21 minutes earlier)