Zap history not loading Zap runs, Zaps are working
Incident Report for Zapier
Resolved
We're happy to share that all Zap runs are available in the Zap history page again, and new Zap runs should show up immediately.

For any additional help, please reach out on: https://zapier.com/app/get-help

Thank you so much!
Posted Apr 22, 2024 - 04:44 PDT
Monitoring
We've identified and resolved the issue. Zap runs are getting added to the Zap history page on an incremental basis—and full functionality is expected to restored in approximately 1 hour.

We'll update the incident once all Zap runs are visible again. Thank you!
Posted Apr 22, 2024 - 03:40 PDT
Investigating
We're currently investigating an issue with the Zap history page not loading Zap runs.

Active Zaps are running as expected in the background, and we're aiming to restore the full experience as quickly as possible.

Thank you for your patience while we're looking into it!
Posted Apr 22, 2024 - 01:59 PDT