Our Engineering team has found and addressed the root cause of the task processing delays. It affected Zapier MCP, with potential delays in the following products: AI Actions, Custom Actions, Functions, Powered by Zapier APIs, Sampling, and Tables.
During the incident, tasks were accepted but processed more slowly than usual, resulting in delayed action runs.
No data loss is confirmed for this incident, and all services are now operating normally. We apologize for any inconvenience this may have caused and appreciate your patience while we investigated and resolved the issue.
If you have any questions, feel free to contact our support team at zapier.com/get-help
Posted Sep 30, 2025 - 06:28 PDT
Update
Our team is investigating an issue affecting a small number of Zapier products. We'll follow up again shortly with more information.
Posted Sep 30, 2025 - 05:01 PDT
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.