During this maintenance window, some users may experience delays with webhooks, and Zapier.com may return 502 (Bad Gateway) or 503 (Service Unavailable) errors. We expect a minimum downtime of 30 minutes, however this behavior may last up to 90 minutes. Posted on
May 23, 2025 - 07:00 PDT
Resolved -
Starting at 15:01 UTC, we were alerted to errors with internal tooling used to monitor Zaps. This was preventing the ability to view internal Zap request logs, specifically in the Developer Portal and UI.
Our team has since released a fix for this issue and functionality has returned.
If you run into any issues regarding this feel free to reach out to our Support team directly.
May 27, 10:05 PDT
Monitoring -
Starting at 15:01 UTC, we were alerted to errors with internal tooling used to monitor Zaps. This was preventing the ability to view internal Zap request logs, specifically in the Developer Portal and UI.
Our team has identified and implemented a possible fix, and we are currently monitoring results to determine full efficacy.
We will update this page with the final resolution once confirmed!
May 27, 08:56 PDT
Investigating -
Starting at 15:01 UTC, we were alerted to errors with internal tooling used to monitor Zaps. This is preventing the ability to view internal Zap request logs.
This currently only impacts the Developer Portal and UI.
Our team is currently investigating the root cause and hope to have a fix available soon. You can subscribe to this page for update.
Resolved -
This incident has been resolved. Find/Search actions should now provide fields to map other actions steps in the Zap.
May 23, 06:52 PDT
Monitoring -
Our Engineering team have identified the source of the issue and implemented a fix. Now, all Find and Search actions should return the expected fields.
We are monitoring this to ensure the issue has been resolved for all users.
May 23, 03:28 PDT
Investigating -
We're currently investigating an issue that is causing Find/Search actions to not return the expected output fields in the Zap Editor.
Our Engineering team is actively investigating this issue, and we will provide more updates as soon as possible.
We really appreciate your patience while we work through this!
May 23, 02:47 PDT
Identified -
The issue has been identified and a fix is being implemented.
May 20, 12:02 PDT
Investigating -
We have received a number of reports from users that are seeing the following error for Webhooks by Zapier steps in their Zaps:
"value.replace is not a function"
We believe this may be due to a regression issue following a recent version update. Our team is currently investigating the root cause of this error and what steps may be necessary to revert to working functionality again.
You can subscribe to this page for updates.
May 20, 09:46 PDT
Resolved -
Earlier today (May 20th), our systems in the Developer Portal/UI encountered a tooling issue that prevented the ability to review request logs.
Our team was able to identify the necessary fix, and this issue has now been resolved.
Thank you for your understanding and patience as we worked on this!
May 20, 10:35 PDT
Monitoring -
Starting at 4:20 PM UTC, we were alerted to errors with internal tooling used to monitor Zaps. This was preventing the ability to view internal Zap request logs, specifically in the Developer Portal and UI.
Our team has identified and implemented a possible fix, and we are currently monitoring results to determine full efficacy.
We will update this page with the final resolution once confirmed!
May 20, 10:03 PDT
Investigating -
Starting at 4:20 PM UTC, we were alerted to errors with internal tooling used to monitor Zaps. This is preventing the ability to view internal Zap request logs.
This currently only impacts the Developer Portal and UI.
Our team is currently investigating the root cause and hope to have a fix available soon. You can subscribe to this page for update.
Resolved -
The incident re-commenced at 10:44 PM UTC and was resolved by 00:06 AM.
During this period, users would have experienced failures and errors in many of their Zaps across several apps. The specific error message displayed was "Object of type datetime is not JSON serializable."
Fortunately, this issue has been addressed and resolved completely. Now, the errored tasks are being replayed, and no additional action is required. We're pleased to inform you that there has been no data loss associated with this incident. All tasks are securely being replayed, and it is expected that future runs will not encounter any similar issues.
We understand the inconvenience caused during this period. If you still experience issues, we encourage you to contact our Support Team through this link: https://zapier.com/app/get-help
We appreciate your patience during this time. Thank you.
May 19, 17:25 PDT
Investigating -
We're currently investigating an re-occurance of a previously issue causing some API responses to fail with the error: "Object of type datetime is not JSON serializable." Please do not hesitate to reach out to us if you experience further issues. Please contact our Support Team here: https://zapier.com/app/get-help
May 19, 15:44 PDT
Resolved -
We experienced a brief issue today starting at 6 PM (UTC). Some Zap runs failed with the error "Object of type datetime is not JSON serializable."
Our team quickly identified the problem and implemented a fix. All affected Zap runs have been successfully replayed.
Thank you for your patience as we resolved this. If you have any questions or notice anything unusual, please don’t hesitate to contact us at https://zapier.com/app/get-help.
May 19, 13:40 PDT
Monitoring -
Our team identified the issue and has implemented a fix. We’re now in the process of replaying any affected Zap runs that encountered the error.
Thank you so much for your patience while we worked through this. If you have any questions or notice anything unusual, feel free to reach out to Zapier Support here: https://zapier.com/app/get-help.
May 19, 12:10 PDT
Investigating -
We’re currently investigating an issue causing some API responses to fail with the error: Object of type datetime is not JSON serializable.
Please do not hesitate to reach out to us if you experience further issues. Please contact our Support Team here: https://zapier.com/app/get-help
May 19, 11:49 PDT
Resolved -
We’ve identified that the error affecting recovery code regeneration for 2FA is limited to a small number of accounts and does not appear to be caused by a broader system failure. As a result, we’re no longer treating this as a widespread incident, but our engineering team is actively working on it as a high priority bug. If you encounter this issue, please reach out to our support team for assistance: https://zapier.com/app/get-help
May 15, 14:15 PDT
Investigating -
We are investigating an issue related to an error when regenerating 2FA recovery codes. Our engineers are actively looking into this. We will update the status page as we find out more!
May 15, 12:35 PDT
Resolved -
The previously reported issue where Zapier Agents were experiencing a 500 error has been resolved. Our Engineering team has successfully addressed the problem, and all systems are now operating normally. We appreciate your patience and understanding during this time. If you continue to experience any issues, please reach out to our support team.
May 15, 14:12 PDT
Monitoring -
We have identified the cause of that issue with Agents and MCP not loading, and have pushed a fix. We are currently monitoring our update to confirm that it has resolved this issue.
We will follow up here with more updates once we have confirmed that this issue issue is resolve.
Thanks again for your patience!
May 15, 11:54 PDT
Investigating -
We are currently investigating an issue where Zapier Agents is unable to load and returning a 500 error.
Our Engineering team is actively investigating this issue, and we will keep this status page updated as we learn more insights into the issue.
We really appreciate your patience while we work through this!
May 15, 11:33 PDT
Resolved -
We’ve resolved the issue that was affecting Slack Triggers, where some output fields were not being returned as expected, leading to missing data errors in some Zaps.
An updated version of the Slack app caused the issue. We have rolled back to the previous version and migrated affected customers, which has restored full functionality.
Thank you for your patience while we worked to resolve this. If you require additional assistance, please feel free to reach out via our Support page: https://zapier.com/app/get-help.
May 15, 08:44 PDT
Investigating -
We are currently investigating an issue where Slack Triggers functionality is affected. Some output fields are not being returned as expected, resulting in missing data errors for some Zaps.
Our Engineering team is actively investigating this issue, and we will keep this status page updated as we learn more insights into the issue.
We really appreciate your patience while we work through this! If you require additional assistance, please feel free to reach out via our Support page: https://zapier.com/app/get-help.
May 15, 07:54 PDT