502 Errors Impacting zapier.com Access and Zap Execution Affected

Incident Report for Zapier

Update

We are continuing to monitor the results of our recent fix. However, users might see Zap runs that are not in a "success" or "filtered" status; they may be in statuses like "playing" or "waiting" instead. We recommend reviewing affected Zap runs and replaying those runs in full to resolve the issues. You can learn more about how to replay entire Zap runs here: https://zapier.com/help/manage/history/replay-failed-zap-runs

We will continue to update the status page with more information as it becomes available. Thank you for your continued patience.
Posted Jun 30, 2025 - 15:23 PDT

Monitoring

At approximately 12:32 PM ET, we began experiencing an issue that affected access to zapier.com and Zap execution. As of 1:30 PM ET, the site is accessible again.

Our engineering team is currently reviewing and processing Zaps that were triggered during the incident window. As a result, some users may notice temporary latency in Zap execution for that time period. Additionally, Zap Editor drafts that were created or edited during the incident window may not have been saved as expected. We’re closely monitoring progress.
Posted Jun 30, 2025 - 11:19 PDT

Investigating

We’re currently investigating an issue resulting in 502 errors across the Zapier platform. This is affecting homepage site access.

Our team is actively working to resolve the issue and restore full functionality. We’ll provide updates as they become available.

Thank you for your patience.
Posted Jun 30, 2025 - 10:04 PDT