Billing settings unavailable
Incident Report for Zapier
Resolved
Billing settings are working normally again. During this issue, Zaps continued to process tasks normally.
Posted Apr 28, 2020 - 14:51 PDT
Identified
It's not currently possible to load billing settings, or make subscription changes. Resolving this is our top priority.

Zaps continue to process tasks normally.
Posted Apr 28, 2020 - 11:54 PDT
This incident affected: Website.