The issue has been Resolved -- Code steps should now function as expected and existing errored runs can be replayed. Any Zaps that were disabled due to high error ratio can now be re-enabled.
On March 30, we experienced an issue that caused Lambda errors in Zap runs using Code steps. We’ve resolved that issue and have taken steps to avoid similar disruptions in the future.
If you run into any additional trouble with Code steps in your Zaps, please reach out to our Support Team: https://zapier.com/app/get-help
We appreciate your patience during this incident and apologies for any inconvenience this might have caused.
Posted Mar 30, 2023 - 07:36 PDT
Monitoring
We've implemented a fix to address an issue that was causing Lambda function errors in Code steps. The fix has now mitigated those impacts, and you should be able to replay effected Zap runs successfully.
Please note that your Zaps continue to run and process as usual -- no impacts or data loss has been experienced during this incident.
We'll continue monitoring and update this StatusPage within then next 24 hours once we're confident the fix has fully resolved the issue. If you have further questions, please reach out to our Support Team here: https://zapier.com/app/get-help
Posted Mar 30, 2023 - 06:06 PDT
Identified
We've identified the issue in the Code steps that are causing Lambda function errors in Zap Runs.
This is affecting Zap Runs that are using both the Python and JavaScript steps in a single Zap.
We're currently working to implement a fix to address this issue and will update StatusPage in two hours at 07:00 PT / 15:00 UTC.