Delays to live runs showing in the Zap run history page.

Incident Report for Zapier

Resolved

Our Engineering team has applied a fix and Zap History page is no longer facing delays.

During the affected period, there wasn't any data loss and everything should be working as expected now.

We apologize for any inconvenience this may have caused.

If you have questions, please contact our support team: https://zapier.com/app/get-help
Posted Jun 25, 2025 - 03:08 PDT

Investigating

We're currently investigating an issue causing delays in the Zap run history page populating live runs.

Our team is actively working to identify and resolve the error. We will provide updates as soon as possible.

Thank you for your patience.
Posted Jun 25, 2025 - 01:11 PDT