Billing settings unavailable
Resolved·Partial outage

Billing settings can be edited normally again. You can use this page here to make changes to your Zapier subscription: https://zapier.com/app/settings/billing

If you ever have any questions, please let us know: https://zapier.com/app/contact-us — we're help to help.

Fri, Mar 20, 2020, 01:01 AM
(5 years ago)
·
Affected components
Updates

Resolved

Billing settings can be edited normally again. You can use this page here to make changes to your Zapier subscription: https://zapier.com/app/settings/billing

If you ever have any questions, please let us know: https://zapier.com/app/contact-us — we're help to help.

Fri, Mar 20, 2020, 01:01 AM

Identified

Right now, Zapier billing settings are unavailable, preventing subscription changes. Our team has identified the source of this issue, and we will post updates on this status page as it is resolved.

Zaps and tasks continue to work normally.

Thu, Mar 19, 2020, 10:42 PM(2 hours earlier)