Updating and creating new Functions causes them to fail

Incident Report for Zapier

Resolved

Earlier today, our team identified an issue that was causing Functions to silently fail, starting on June 5, 2025 at 10:34:06 PM UTC.

Functions that were created and updated during this timeframe did not run as expected. We apologize for any inconvenience this may have caused.

We were able to identify the issue and fix it. Functions should now be working without issues.

Feel free to reach out to our Support team if something's still not as you expect: https://zapier.com/app/get-help
Posted Jun 09, 2025 - 06:33 PDT

Investigating

We're currently investigating an issue that is impacting Functions.

Updating existing Functions and creating new ones is causing them to fail silently and not execute as expected.

Existing Functions that are have not been updated are continuing to work as expected.

Our team has identified the issue, and we'll provide an update as soon as we know more and it is resolved.
Posted Jun 09, 2025 - 04:43 PDT