Issues With our Upstream Provider Causing Availability Issues
Incident Report for Zapier
Resolved
Everything is back to normal. If you got any error emails from Zapier or noticed pending tasks in your task history - this is what you can do to recover tasks:

1. If you had Autoreplay on - you do not have to do anything - we will continue to replay any errors until they succeed.
2. If you did not have Autoreplay on - you can replay each task - even as a free user (we've enabled it for all plans for this week).

Both Autoreplay and manual replay can be enabled or performed on your Task History page - located at https://zapier.com/app/history.

If you have any other questions don't hesitate to contact us https://zapier.com/app/contact-us.
Posted Feb 28, 2017 - 18:12 PST
Monitoring
Everything is back up to speed - all pending tasks should be resuming. There are a few lingering errors being resolved right now (mostly around Code and developer apps).

To all users with errors in your Task History - we've enabled free replaying (normally a paid feature) for all users so you can recover any tasks stuck in an error state due to the outage. If you see anything odd in your account and you need a hand - don't hesitate to contact us https://zapier.com/app/contact-us.

The root cause was our upstream provider's (AWS) very popular file storage system (S3) started failing - which caused many issues for numerous websites across the internet - Zapier included. We are beginning the process of reviewing internal logs so we can identify improvements and build a more robust system.

We'll post once more as soon as we're 100% sure everything is resolved.
Posted Feb 28, 2017 - 15:22 PST
Update
Most services are recovering now - expect to see a lot of tasks temporarily stuck in Pending while Zaps catch back up. We're on track to be fully caught up in roughly an hour - barring any new surprises with our upstream provider (https://status.aws.amazon.com/).
Posted Feb 28, 2017 - 14:21 PST
Update
Things are looking like they are resolving slowly with the upstream provider, but we're still seeing intermittent blips with site availability. We expect this to continue before normalizing. Zaps are running, and there is a very large webhook backlog for instant Zaps we're working through now.
Posted Feb 28, 2017 - 13:02 PST
Update
We continue to monitor the outage of our upstream provider (https://status.aws.amazon.com/) while actively working to re-route all Zaps and get them working as fast as possible. While we have a large backlog of webhooks to work through, we're making good progress.
Posted Feb 28, 2017 - 11:45 PST
Identified
We're currently experiencing impacted availability from our upstream service provider. Polling will be delayed and some zapbook pages may not render while we investigate and monitor the situation.
Posted Feb 28, 2017 - 10:10 PST