Invoices may not be accessible on the Settings page.
Incident Report for Zapier
Resolved
Past invoices are loading normally again. You can use https://zapier.com/app/settings/billing to review past and upcoming invoices.
Posted Mar 30, 2021 - 14:22 PDT
Identified
We have identified an issue where Invoices may not be accessible on the Settings > Billing page. We working on resolving the issue as soon as possible, and we will update this status page with more details on how things will return to normal.
Posted Mar 30, 2021 - 13:51 PDT
This incident affected: Website.