Website issues
Incident Report for Zapier
Resolved
Zapier.com is now back to normal - sorry for the interruption!
Posted Sep 27, 2016 - 06:11 PDT
Monitoring
We are currently having some issues with the zapier.com website. The issue has been identified and response times are improving.
Posted Sep 27, 2016 - 05:54 PDT