Site Slowness
Incident Report for Zapier
Resolved
This incident has been resolved and any Tasks that were delayed should have been played.
Posted Oct 15, 2019 - 08:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2019 - 06:49 PDT
Investigating
We have identified an issue with site slowness and occasional failure to load. Our engineers are hard at work on a fix and we will update this status page with more details when things return to normal.
Posted Oct 15, 2019 - 06:38 PDT
This incident affected: Website.