Delay in executing for Google Sheets 'Add Row' action.

Incident Report for Zapier

Resolved

This incident has been resolved. We are working on getting task history caught back up.
Posted Jul 29, 2025 - 13:20 PDT

Investigating

We are currently investigating an issue where Google Sheets 'Add Row' actions will be delayed in executing.

Our team has found the cause of the delay in those completing and is actively working on a fix for this. No data loss is currently expected.

If you need help, contact support here: https://zapier.com/app/get-help
Posted Jul 29, 2025 - 12:53 PDT
This incident affected: Zaps (Searches & Writes).