Resolved
This incident has been resolved.Thank you so much for your patience!
Monitoring
A fix has been implemented and we are monitoring the results. Delayed Zap runs should be processed within the next hour
Identified
We have identified the issue and are working on resolving it.
Investigating
We are currently investigating an issue that is affecting around 2,5% of the Zaps where both instant and polling triggers are delayed, as well as Zap runs not proceeding to the next step immediately.
Our engineers are actively working on a resolution. Please accept our sincerest apologies for this inconvenience, we'll keep in touch regularly.