Problems saving changes to profiles
Incident Report for Zapier
Resolved
Changes to profile and billing information are saving normally. Users should now be able to create/edit folders, change profile information, and update billing details as expected.

If you're ever seeing anything that doesn't look quite right, our Support team is here to help: https://zapier.com/app/contact-us
Posted Mar 03, 2020 - 15:14 GMT
Monitoring
Our engineering team has identified the issue, implemented a fix, and is monitoring to confirm when everything is back to normal.
Posted Mar 03, 2020 - 15:05 GMT
Investigating
Some users are reporting having trouble making changes to their profiles, including creating/editing folders, updating billing information, and changing profile information. If you are experiencing trouble while trying to update your profile or billing information, please follow this issue for future updates.
Posted Mar 03, 2020 - 14:16 GMT
This incident affected: Website.