Users may not be able to submit Support tickets
Incident Report for Zapier
Resolved
This issue has been fully resolved. All users should be able to submit tickets to Zapier Support. We appreciate your patience!
Posted Feb 16, 2024 - 12:24 PST
Monitoring
Users should be able to submit Support tickets successfully through the Zapier contact form: https://zapier.com/app/get-help

Our team is currently monitoring this issue. If you continue seeing errors, please notify our Support team via live chat.

Thank you for your patience as we worked to resolve this issue!
Posted Feb 16, 2024 - 11:26 PST
Investigating
We're currently experiencing an issue where some users are receiving a 400 error when they attempt to submit a Support ticket through the Zapier contact form. https://zapier.com/app/get-help

In the meantime, you can reach us via live chat support for urgent issues. We appreciate your patience while we resolve the issue.
Posted Feb 16, 2024 - 11:07 PST