Spike in Zap triggers not processing as expected
Incident Report for Zapier
Resolved
The incident which initiated at 16:00 UTC has been fully resolved as of 16:02 UTC.

During this brief period, users may have experienced an unexpected increase in Zap triggers not processing correctly.

Our team has identified the minimal missed Zap Triggers and is currently in the process of reaching out to any users that may have been impacted.

If you experience any further issues, we encourage you to contact our customer support. We appreciate your understanding and patience, and we apologize for any inconvenience this may have caused.
Posted Jun 12, 2024 - 16:13 PDT
Investigating
Our team is currently investigating a spike in Zap triggers not processing as expected between 16:00 and 16:02 UTC. We'll continue to keep this Status Page up to date.
Posted Jun 12, 2024 - 12:22 PDT