Various apps returning errors
Incident Report for Zapier
Resolved
On October 8, 2024, between 15:41 UTC and 18:10 UTC, an issue with certain integrations in Zapier may have impacted data passed between your Zap triggers and actions. During this period, we identified two separate issues:

1. Google Sheets Trigger and Action Failures

Some Google Sheets triggers and actions failed with error messages but have since been replayed. The data from these Zap runs should now be considered accurate.

2. Mismatched Zap Runs

Certain Zap triggers may have used data from previous Zap runs. While no data was transferred between different Zaps, connected accounts, or Zapier accounts, unintended or incorrect data may have been transferred within your Zaps.

Recommended Action

Since these Zap runs did not technically fail, we are unable to replay them or automatically identify which data may be incorrect.

If you have workflows involving the affected apps during the incident window, we strongly recommend manually reviewing any data passed between apps during this time to ensure no inaccurate data has been transferred or acted upon.

You can use Zap History with date and app filters to identify potentially impacted runs. To review this information, visit this preset Zap History view.

For any Zap runs where only the actions had erroneous data, you can utilize the Replay entire Zap run feature. This will replay an entire Zap run from the trigger step. If the trigger data is accurate, the automation will carry out as originally expected. Learn more about this feature here: Replay entire Zap run.

Next Steps

We have addressed the root cause of the issue and are implementing preventive measures to avoid future occurrences.

If you need any help or have questions about this, please contact our support team via the help page.
Posted Oct 09, 2024 - 15:28 PDT
Update
Our team has addressed this issue and a resolution has been added.
Posted Oct 09, 2024 - 15:27 PDT
Monitoring
Our team identified and addressed an issue that was causing errors and irregular data in various apps today. Some users may have run into "Unable to parse range" errors in Google Sheets specifically.

The incident was recognized at 15:12 UTC and the fix was implemented by 18:10 UTC.

For those who received the given error message, replaying the Zap should help to resolve the issue: https://help.zapier.com/hc/en-us/articles/8496241726989-Replay-failed-Zap-runs

Please note, we are monitoring the situation closely to ensure the full resolution of the incident.
Posted Oct 08, 2024 - 13:32 PDT
Investigating
We are currently investigating an issue where various apps are returning errors or incorrect data in live Zap runs.

If your Zap returns an error, it should be resolved by replaying the Zap run.

https://help.zapier.com/hc/en-us/articles/8496241726989-Replay-failed-Zap-runs

We will update here as soon as we have additional information.
Posted Oct 08, 2024 - 11:25 PDT
This incident affected: Zaps (Instant Triggers, Polling Triggers, Searches & Writes).