Increased number of 503 errors with Google Ads actions

Incident Report for Zapier

Resolved

This incident has been resolved. Google has confirmed that they had resolved the issue with Google Ads based on their their Status Page here: https://ads.google.com/status/publisher/incidents/xF9wKox7evao5WupR7mu.

Our team will be replaying the errored Zap runs related to this incident. No actions is required from customers at this time.

If you continue to encounter any issues related to this, kindly reach out to our Support Channel (https://zapier.com/app/get-help). Thank you.
Posted Jul 02, 2025 - 23:33 PDT

Identified

Google Ads has confirmed that they are currently investigating an issue with the Google Ads platform. You can find more updates here:
https://ads.google.com/status/publisher/incidents/xF9wKox7evao5WupR7mu
Posted Jul 02, 2025 - 16:49 PDT

Investigating

We are currently investing reports of an increase in 503 errors from actions within the Google Ads integration ( such as then Send Offline Conversion, Create Customer List, and Set Campaign List actions).

We will update here once we have more information
Posted Jul 02, 2025 - 15:50 PDT