Delay steps are not releasing since approximately 9am UTC
Incident Report for Zapier
Resolved
Delay steps should now be running again and any existing held Delay steps will be catching up and releasing soon.

If you have any questions or need further help with this, please contact us at https://zapier.com/contact and we'll be happy to assist.
Posted 4 months ago. Aug 06, 2018 - 06:47 PDT
Identified
We are aware that Delay steps are not allowing the Zap to continue after the Delay period is over. This started around 9am UTC. Our engineers are investigating.

In the meantime, if contact us with the affected Zap via https://zapier.com/app/contact-us, we may be able to release the affected Zap for you.
Posted 4 months ago. Aug 06, 2018 - 05:39 PDT
This incident affected: Apps.