Task Processing Delayed
Incident Report for Zapier
Resolved
We've replayed all the Hooks and Tasks that were delayed throughout the outage. Everything is now running like normal! If you are still missing Tasks, please email us contact@zapier.com for help!

The core issue is related to how a message broker stopped passing along messages at any appreciable speed -- we're unsure of the root cause of this, but it seems to have resolved completely with a full cluster restart. We will be doing some active investigations and will report back as we have more information.
Posted 8 months ago. Mar 12, 2018 - 16:04 PDT
Update
Hooks are currently getting replayed, other Tasks (like those in pending) will be replayed shortly! We'll update you as soon as we have more information.
Posted 8 months ago. Mar 12, 2018 - 11:32 PDT
Monitoring
Looks like task are flowing again, we're watching it closely right now. We'll continue updating over the next few hours as we replay tasks that were delayed.
Posted 8 months ago. Mar 12, 2018 - 09:33 PDT
Identified
We're working to recover our primary task queue which is behaving strangely. Expect tasks to be completely delayed until we resolve.
Posted 8 months ago. Mar 12, 2018 - 09:23 PDT
Investigating
Task processing is currently delayed while we investigate an ongoing backend issue.
Posted 8 months ago. Mar 12, 2018 - 08:52 PDT