JotForm Issues
Incident Report for Zapier
Resolved
JotForm is operating normally again. If you don't have Autoreplay enabled, consult your task history to replay any failed tasks.
Posted Mar 31, 2016 - 12:24 PDT
Monitoring
JotForm is currently experiencing an outage at their primary datacenter, and is in the process of switching over to a secondary facility. We're monitoring the situation and will provide an update when requests to JotForm have successfully recovered.
Posted Mar 31, 2016 - 11:36 PDT