Zapier.com Login and /app pages not working on Firefox and Safari
Incident Report for Zapier
Resolved
This incident has been resolved - Zapier is loading consistently on Safari and Firefox.
Posted 19 days ago. Aug 01, 2019 - 12:52 PDT
Monitoring
We have released a fix for this issue - Zapier pages should now load as expected on both Firefox and Safari.
Posted 19 days ago. Aug 01, 2019 - 11:36 PDT
Identified
We have identified an issue where Zapier pages do not load properly on Firefox and Safari. Chrome loads properly, so we recommend using Chrome for now if you need to access your Zaps urgently! Our engineering team is working on a fix for this and it should be released shortly.
Posted 19 days ago. Aug 01, 2019 - 10:28 PDT
This incident affected: Website.