Slow loading on zapier.com
Incident Report for Zapier
Resolved
Loading speeds on zapier.com have returned to normal.

During this incident, Zaps continued to work normally. We are implementing changes to prevent this same issue from happening again.

If you're ever seeing anything that doesn't work the way you expect, our support team can help to take a closer look: https://zapier.com/app/contact-us
Posted 3 months ago. Jul 18, 2019 - 10:16 PDT
Monitoring
A fix has been deployed for the site slowness and we are monitoring the results.
Posted 3 months ago. Jul 18, 2019 - 08:13 PDT
Identified
Our team has identified the cause of slow loading on zapier.com, and we're working to resolve this issue.

Right now, you might not be able to edit Zaps that are stored in shared folders, or you might find that the Zap editor feels laggy. But all of your Zaps that are turned on continue to work normally.

Thank you for your patience as we fix this problem.
Posted 3 months ago. Jul 18, 2019 - 07:10 PDT
Investigating
Our team is investigating reports that some zapier.com pages aren't loading as fast as we normally expect. When viewing your folders of Zaps, shared folders might not appear right away. When editing Zaps, you might find things move slower than normal.

All of your Zaps that are turned on continue to work normally. This issue only affects loading pages on zapier.com

We'll keep this status page updated as we investigate and resolve this issue.
Posted 3 months ago. Jul 18, 2019 - 06:12 PDT
This incident affected: Website.