Delayed Zap Triggers
Incident Report for Zapier
Resolved
After monitoring this issue, we can confirm that all triggers should be running as expected.

Note: There is currently a separate incident impacting Meta Zaps: https://status.zapier.com/incidents/tpnj4qp8f845
Posted Mar 05, 2024 - 09:01 PST
Monitoring
Between 14:55 UTC and 15:50 UTC, customers may have noticed a delay of up to 8 minutes in some Zap triggers. Our engineers have identified the source of the issue and all triggers should be processing as normal. We apologize for any inconvenience caused by this.
Posted Mar 05, 2024 - 08:04 PST