Zapier Logins and Signups using Google SSO may be slow to process or return a 502 error
Incident Report for Zapier
Resolved
Due to a larger overarching issue with Google failures, users began to see login failures while attempting to login to Zapier via Google SSO. The issue began at 7:07 PM UTC and was fully resolved by 9:22 PM UTC.

This issue has been resolved. Users should now be able to log in as usual, without the need for any workarounds.

We apologize for any inconvenience and disruption this may have caused. Should you encounter any further issues, please get in touch with our support team.

https://zapier.com/app/get-help
Posted Dec 07, 2023 - 14:21 PST
Monitoring
Our team has identified the issue and implemented a fix. We're now monitoring the results.

Users can still login via username/password if they have previously set a password. Users who have not already set a password can use 'Forgot password' to set one up and login via username/password.

We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything: https://zapier.com/app/get-help
Posted Dec 07, 2023 - 13:34 PST
Investigating
We're currently experiencing an issue where logins and signups using Google SSO are slow to process or return a 502 error for a subset of users.

We're currently investigating this issue and working to restore access to Google SSO.

Users can still login via username/password if they have previously set a password. Users who have not already set a password can use 'forgot password' to set one up and login via username/password.

We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything: https://zapier.com/app/get-help
Posted Dec 07, 2023 - 12:16 PST
This incident affected: Website.