Slack triggers experiencing significant delays or missing triggers

Incident Report for Zapier

Resolved

We’ve finished sending out the Slack alerts that got stuck, and everything is caught up. Your Zaps with the Slack trigger should now run smoothly without delays. Thanks for bearing with us!
Posted 13 days ago. May 09, 2025 - 10:26 PDT

Update

We are continuing to investigate this issue.
Posted 13 days ago. May 09, 2025 - 10:12 PDT

Investigating

Users may have experienced delays with their Slack triggers, with slowdowns lasting approximately 10–20 minutes. This initially appeared to be resolved by 8th May 2025 - 17:34 UTC thanks to the efforts of our team. However, we are aware that the issue has resurfaced and are actively investigating it once again.

We want to reassure users that no data loss has been observed. If you continue to encounter issues, please don’t hesitate to reach out to our support team at https://zapier.com/app/get-help.

We sincerely apologize for the inconvenience and thank you for your continued patience.
Posted 13 days ago. May 09, 2025 - 06:37 PDT