This issue has been resolved, and agent executions are operating normally.
Between April 6, 2026, at 22:12 UTC and 22:47 UTC, a dependency that powers Agents became unavailable due to internal load test traffic.
Agents triggered during this window may have failed to execute and will not be automatically retried. Agents that run from a Zap have been replayed and succeeded as well.
If an agent run failed during this window, re-run the agent (or trigger it again via its normal trigger mechanism). New executions should now succeed.
We apologize for the disruption. If you’re still seeing the issue, please refresh and try again, or contact Support at https://zapier.com/app/get-help.
Resolved
This issue has been resolved, and agent executions are operating normally.
Between April 6, 2026, at 22:12 UTC and 22:47 UTC, a dependency that powers Agents became unavailable due to internal load test traffic.
Agents triggered during this window may have failed to execute and will not be automatically retried. Agents that run from a Zap have been replayed and succeeded as well.
If an agent run failed during this window, re-run the agent (or trigger it again via its normal trigger mechanism). New executions should now succeed.
We apologize for the disruption. If you’re still seeing the issue, please refresh and try again, or contact Support at https://zapier.com/app/get-help.
Monitoring
We are currently monitoring an issue affecting agent executions. Between April 6, 2026, at 22:12 UTC and 22:47 UTC, one of our services that powers Agents became unavailable due to internal load test traffic, which prevented agents from executing properly during this approximately 35-minute window.
During this time, agents that were triggered experienced failures and were unable to complete. We are monitoring the underlying issue, and the service is now operating normally.
We are continuing to investigate the full scope of impact and will provide additional updates as we gather more information. We sincerely apologize for any disruption this may have caused.