Task Usage Page Currently Unavailable
Resolved

This issue is now resolved, and the Task Usage Page should now be loading correctly for all users.

If you are running into any other issues, please reach back out to Zapier Support: https://zapier.com/app/get-help

Wed, Feb 25, 2026, 05:56 PM
(11 hours ago)
·
Affected components

No components marked as affected

Updates

Resolved

This issue is now resolved, and the Task Usage Page should now be loading correctly for all users.

If you are running into any other issues, please reach back out to Zapier Support: https://zapier.com/app/get-help

Wed, Feb 25, 2026, 05:56 PM

Monitoring

The issue affecting the Task Usage page has been resolved. Customers should now be able to view task usage data in the UI as expected.

We appreciate your patience while our team worked to restore full visibility. Please reach out to support if you continue to experience any issues.

Wed, Feb 25, 2026, 04:32 PM(1 hour earlier)

Investigating

We’re currently investigating an issue affecting the Task Usage page. At the moment, some customers may not be able to view their task usage data in the UI.

Our engineering team is actively working to resolve this and restore visibility to the Task Usage page as quickly as possible. We’ll continue to share updates as soon as we have more information.

If you have any questions, reach out to our support team here: https://zapier.com/app/get-help

Wed, Feb 25, 2026, 03:58 PM(34 minutes earlier)