AI byZapier actions are stuck in Delay status
Resolved

If you had AI by Zapier actions there are stuck in the delayed status please visit your Zap History here to view any Delayed status AI by Zapier Zap Runs and decide to replay the entire run for completion. Unlike replaying errors, when you replay all steps, the Zap will replay every single step in the Zap, including the trigger and all previous steps, regardless of their run status. Below are instructions on recommended actions to take: 1. Visit Zap History for October 29th with a status of Scheduled for AI by Zapier connection: https://zapier.com/app/history?end_datetime=2025-10-29&start_datetime=2025-10-29&app=AICLIAPI%403.5.0&status=delayed 2. Ensure the date range shows October 29th and review runs between the impacted time. 3. View the Zap Run and follow the instructions below to replay the entire Zap run. To replay the entire run, please follow the steps below from this help guide:

  • Open the Zap in the Zap editor.

  • In the left sidebar, click the Zap runs icon to expand it.

  • Select one or more Zap runs.

  • Above the Zap runs, click Replay. A dialog box will appear.

  • Click Replay.

If you have any issues with the steps above please contact support: https://zapier.com/app/get-help

Wed, Oct 29, 2025, 08:21 PM
(1 day ago)
·
Affected components

No components marked as affected

Updates

Resolved

If you had AI by Zapier actions there are stuck in the delayed status please visit your Zap History here to view any Delayed status AI by Zapier Zap Runs and decide to replay the entire run for completion. Unlike replaying errors, when you replay all steps, the Zap will replay every single step in the Zap, including the trigger and all previous steps, regardless of their run status. Below are instructions on recommended actions to take: 1. Visit Zap History for October 29th with a status of Scheduled for AI by Zapier connection: https://zapier.com/app/history?end_datetime=2025-10-29&start_datetime=2025-10-29&app=AICLIAPI%403.5.0&status=delayed 2. Ensure the date range shows October 29th and review runs between the impacted time. 3. View the Zap Run and follow the instructions below to replay the entire Zap run. To replay the entire run, please follow the steps below from this help guide:

  • Open the Zap in the Zap editor.

  • In the left sidebar, click the Zap runs icon to expand it.

  • Select one or more Zap runs.

  • Above the Zap runs, click Replay. A dialog box will appear.

  • Click Replay.

If you have any issues with the steps above please contact support: https://zapier.com/app/get-help

Wed, Oct 29, 2025, 08:21 PM

Monitoring

We have implemented a fix for this issue, and are monitoring the results to confirm whether that was able to resolve this issue with those runs being stuck in a Delayed state going forward.

Wed, Oct 29, 2025, 04:24 PM(3 hours earlier)

Investigating

We are currently investigating an issue impacting Al by Zapier actions. Some actions are unexpectedly getting stuck in a "Delay" status, which began a few hours ago. Our team is actively working on identifying the root cause. We will provide another update as soon as we have more information. We apologize for any inconvenience this may cause.

Wed, Oct 29, 2025, 03:57 PM(26 minutes earlier)