Delay by Zapier: Server Error (500)
Resolved

Starting around 7:30am PST / 2:30pm UTC, we began receiving reports of 500-level “Internal Server Error” messages with the Delay by Zapier app, which prevented some Zap runs from completing as expected. Our engineering team identified the root cause and implemented a fix. The issue has now been fully resolved, and the tasks will be replayed without manual intervention. There was no data loss during this incident. However, because this impacted Delay steps, the timing of some Zap actions during the incident may differ slightly from the configured schedule. We’re continuing to monitor the situation, but everything is now operating normally. If you see any additional errors, please don’t hesitate to let us know.

Sun, Oct 12, 2025, 06:28 PM
(1 month ago)
·
Affected components

No components marked as affected

Updates

Resolved

Starting around 7:30am PST / 2:30pm UTC, we began receiving reports of 500-level “Internal Server Error” messages with the Delay by Zapier app, which prevented some Zap runs from completing as expected. Our engineering team identified the root cause and implemented a fix. The issue has now been fully resolved, and the tasks will be replayed without manual intervention. There was no data loss during this incident. However, because this impacted Delay steps, the timing of some Zap actions during the incident may differ slightly from the configured schedule. We’re continuing to monitor the situation, but everything is now operating normally. If you see any additional errors, please don’t hesitate to let us know.

Sun, Oct 12, 2025, 06:28 PM

Monitoring

Starting around 7:30am PST/2:30pm UTC, we began receiving reports of 500-level Internal Server errors with the Delay by Zapier app. This prevented Zap runs from completing as expected. An initial fix has been deployed, and our team is monitoring error rates to ensure all details have been addressed.

Sun, Oct 12, 2025, 05:48 PM(39 minutes earlier)

Investigating

Starting around 7:30am PST/2:30pm UTC, we began receiving reports of 500-level Internal Server errors with the Delay by Zapier app. This is preventing Zap runs from completing as expected. Our engineering team is currently investigating the root cause, as well as possible solutions. If you have questions, please contact Support at https://zapier.com/app/get-help.

Sun, Oct 12, 2025, 04:43 PM(1 hour earlier)