Resolved
This incident has been resolved - Zaps are loading and running as expected.
Monitoring
The issue has been identified and most services have returned to normal. We will continue to monitor and update again when fully resolved.
Investigating
We have identified an issue where Zaps are loading and running slowly. Our engineering team is working on a fix for this and it should be released shortly.