Changes to profile and billing information are saving normally. Users should now be able to create/edit folders, change profile information, and update billing details as expected.
If you're ever seeing anything that doesn't look quite right, our Support team is here to help: https://zapier.com/app/contact-us
No components marked as affected
Resolved
Changes to profile and billing information are saving normally. Users should now be able to create/edit folders, change profile information, and update billing details as expected.
If you're ever seeing anything that doesn't look quite right, our Support team is here to help: https://zapier.com/app/contact-us
Monitoring
Our engineering team has identified the issue, implemented a fix, and is monitoring to confirm when everything is back to normal.
Investigating
Some users are reporting having trouble making changes to their profiles, including creating/editing folders, updating billing information, and changing profile information. If you are experiencing trouble while trying to update your profile or billing information, please follow this issue for future updates.