Resolved
This issue was resolved, and Zaps are triggering at their expected speeds. If you have any questions, please contact us: https://zapier.com/app/get-help
Monitoring
We are continuing to monitor for any further issues.
Monitoring
We are continuing to monitor for any further issues.
Monitoring
Task processing is recovering and we will continue to monitor the situation.
Investigating
Some Zap workflows are taking longer than normal to start performing actions. New data continues to be received from other apps, but may be a several minute lag before triggering workflows.