Zapier

Contact SupportSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Zap History not displaying Zap runs
Resolved·Partial outage

We have implemented a fix regarding Zap history runs not showing, so they should be available in your Zap history page now.

If you have questions or need help, please contact our Support team at: zapier.com/get-help.

Wed, Sep 9, 2026, 07:41 PM
(14 hours ago)
·
Affected components
Sep 9, 2026, 05:51 PM
07:41 PM
Updates

Resolved

We have implemented a fix regarding Zap history runs not showing, so they should be available in your Zap history page now.

If you have questions or need help, please contact our Support team at: zapier.com/get-help.

Wed, Sep 9, 2026, 07:41 PM

Monitoring

The Engineering team has implemented a fix for this issue, and Zap runs continue to load into the Zap History.

Executions have not been affected: Zap runs are executing normally. However, the Zap run data was not rendering in the Zap history correctly.

We appreciate your patience while we worked through this, and we will share a final update once all Zap runs are displaying successfully.

If you have questions or need help, please contact our Support team at: zapier.com/get-help.

Wed, Sep 9, 2026, 06:59 PM(42 minutes earlier)

Identified

We've identified the root cause for Zap runs not displaying in the Zap History, and our Engineering team is working on a resolution.

Zap runs are slowly appearing again in the Zap history, and we'll confirm once all Zap runs can be accessed.

For any questions, please reach out to our Support team at: zapier.com/get-help.

Wed, Sep 9, 2026, 06:14 PM(45 minutes earlier)

Investigating

We're currently experiencing an issue where the Zap History page is not displaying recent Zap runs happening from today, September 9, 2026 starting at approximately 12:39PM EST.

Zap runs are still processing normally, but can't be accessed or reviewed at the moment.

We're actively investigating and will continue to update this status page with our progress.

Many thanks for your patience! If you have any questions, please contact our Support team at: zapier.com/get-help.

Wed, Sep 9, 2026, 05:51 PM(22 minutes earlier)