A fix has been implemented and we are monitoring the results.
We have not seen any new instant trigger failures since approximately 10:26 AM PDT (17:26 UTC). The change we deployed adds automatic retries for the failure that was preventing a small number of triggers from firing, and we are continuing to roll it out fully.
No data has been lost. We have confirmed that affected triggers replay successfully, and we are now replaying the triggers that failed during this incident.
Our team is monitoring closely to confirm the issue is fully resolved.
If you have any questions, please reach out to our support team: https://zapier.com/app/get-help
Thank you for your patience.
Monitoring
A fix has been implemented and we are monitoring the results.
We have not seen any new instant trigger failures since approximately 10:26 AM PDT (17:26 UTC). The change we deployed adds automatic retries for the failure that was preventing a small number of triggers from firing, and we are continuing to roll it out fully.
No data has been lost. We have confirmed that affected triggers replay successfully, and we are now replaying the triggers that failed during this incident.
Our team is monitoring closely to confirm the issue is fully resolved.
If you have any questions, please reach out to our support team: https://zapier.com/app/get-help
Thank you for your patience.
Investigating
We're continuing to investigate a small number of workflows that failed to start between approximately 9:00–9:20 AM UTC on August 25.
Affected triggers did not fire during this window. No data has been lost — failed triggers can be replayed once the issue is resolved.
Our team is actively working to determine the root cause. We'll provide another update as soon as possible.
If you need help: https://zapier.com/app/get-help
Investigating
Some customers may experience intermittent delays or failures with instant triggers, which can prevent workflows from starting. We are investigating the issue and working to restore normal processing.
We will provide updates as soon as possible.