We’ve deployed a fix for the issue that caused some Contact Sales forms to fail to load. We’re monitoring the form closely to confirm the improvement holds.
If you need to contact our Sales team and are unable to load the form, please feel free to create a ticket with Support (https://zapier.com/app/get-help), and we'll route the ticket accordingly.
Monitoring
We’ve deployed a fix for the issue that caused some Contact Sales forms to fail to load. We’re monitoring the form closely to confirm the improvement holds.
If you need to contact our Sales team and are unable to load the form, please feel free to create a ticket with Support (https://zapier.com/app/get-help), and we'll route the ticket accordingly.
Identified
Our Engineering team has observed increased traffic to our Contact Sales form, causing it to reach our vendor's rate limit and fail to load.
We're continuing our work to resolve the issue, but if you need to contact our Sales team and are unable to load the form, please feel free to create a ticket with Support (https://zapier.com/l/contact-sales), and we'll route the ticket accordingly.
Investigating
We're currently investigating an issue where our Contact Sales
form on the homepage does not load. Our team is actively working on identifying and resolving the issue.
In the meantime, if you would like to contact our Sales team, please submit a ticket through our Support team here: zapier.com/get-help, and we'll be happy to assist and/or route you to the appropriate team.