We have successfully resolved the Salesforce connection issues that affected some of our customers earlier today.
What Happened
A recent update to our Salesforce integration caused authentication failures for users who were automatically migrated to the new version. Customers attempting to connect or reconnect their Salesforce accounts received an error message.
What We Did
Our team quickly identified the root cause, stopped further migrations, and rolled back all affected users to a previous working version. We then systematically reactivated all affected Salesforce connections and replayed any impacted Zap runs to ensure no data was lost.
Resolution
All Salesforce connections have been restored and are now working normally. Your Zaps should resume processing automatically. If you experienced any issues earlier today, your connections are now active and ready to use.
Thank You
We sincerely apologize for this disruption and appreciate your patience as we worked to resolve this issue. If you have any questions or continue to experience problems, please contact our support team at https://zapier.com/app/get-help.
Thank you for your continued trust in Zapier.
No components marked as affected
Resolved
We have successfully resolved the Salesforce connection issues that affected some of our customers earlier today.
What Happened
A recent update to our Salesforce integration caused authentication failures for users who were automatically migrated to the new version. Customers attempting to connect or reconnect their Salesforce accounts received an error message.
What We Did
Our team quickly identified the root cause, stopped further migrations, and rolled back all affected users to a previous working version. We then systematically reactivated all affected Salesforce connections and replayed any impacted Zap runs to ensure no data was lost.
Resolution
All Salesforce connections have been restored and are now working normally. Your Zaps should resume processing automatically. If you experienced any issues earlier today, your connections are now active and ready to use.
Thank You
We sincerely apologize for this disruption and appreciate your patience as we worked to resolve this issue. If you have any questions or continue to experience problems, please contact our support team at https://zapier.com/app/get-help.
Thank you for your continued trust in Zapier.
Monitoring
We have rolled back the problematic update and confirmed that Salesforce connections are now working properly.
What you need to do: If you experienced an error when trying to connect or reconnect Salesforce, your connection should now work. You can reconnect your connection, and it will be restored to active status.
Next Steps
We will provide another update once we have completed the fix. We sincerely apologize for this disruption and appreciate your patience as we work to fully resolve this issue.
For support inquiries, please contact our support team at https://zapier.com/app/get-help.
Identified
We have identified the root cause of the Salesforce connection failures and are actively working to resolve the issue.
What Happened
Our investigation identified that a recent update to the Salesforce integration caused this issue for users who were automatically migrated to the new version.
Who Is Affected
Only users who were automatically migrated to the latest version of the Salesforce integration and then attempted to reconnect their Salesforce account are affected. If you have not tried to reconnect Salesforce since this morning, you may not have experienced any disruption.
What We're Doing
Our engineering team is deploying a fix that will resolve this issue. We have stopped further automatic migrations and are preparing to move affected users to the corrected version.
What You Need to Do
If you received an error when trying to connect or reconnect Salesforce, you will need to reconnect your Salesforce account once we have deployed the fix. We will send you detailed instructions on how to do this.
Next Steps
We will provide another update with confirmation when the fix has been deployed. We sincerely apologize for this disruption and appreciate your patience as we work to resolve this issue.
For support inquiries, please contact our support team.
Investigating
We are currently investigating an issue affecting Salesforce connections. Users attempting to add or reconnect Salesforce integrations are receiving a "Cross-org Auth flows are not supported for this external client app" error and a 400 error response.
What's Happening
Starting at approximately 09:42 CET on August 6, 2026, users have been unable to authenticate or reconnect Salesforce accounts. This issue is affecting multiple versions of the Salesforce integration.
What We're Doing
Our engineering team has identified a recent code change as the likely cause and we are actively working to restore functionality and will provide updates as soon as we have more information.
Next Steps
We will post another update within the next 30 minutes with either a resolution or a more detailed timeline. We apologize for the disruption and appreciate your patience as we work through this issue.
For support inquiries, please contact our support team.