Earlier today, some Translate by Zapier requests failed with 403 “User Rate Limit Exceeded” errors due to a Google Integrations Production Google Cloud billing configuration issue.
This has been resolved and we’re seeing successful translations again with no ongoing errors.
If you had Zap runs fail during the incident window, you may need to replay those runs to complete processing.
If you experience any ongoing issues, contact Support: https://zapier.com/app/get-help
Thank you for your patience.
No components marked as affected
Resolved
Earlier today, some Translate by Zapier requests failed with 403 “User Rate Limit Exceeded” errors due to a Google Integrations Production Google Cloud billing configuration issue.
This has been resolved and we’re seeing successful translations again with no ongoing errors.
If you had Zap runs fail during the incident window, you may need to replay those runs to complete processing.
If you experience any ongoing issues, contact Support: https://zapier.com/app/get-help
Thank you for your patience.
Investigating
We are currently investigating elevated error rates affecting the Translate by Zapier integration. Starting at approximately 2:00pm UTC on July 20, 2026, users of this integration have been experiencing 403 "User Rate Limit Exceeded" errors when attempting to use the translation features.
What's Happening
Our investigation has identified that the Google Cloud Translation API v2 is returning rate limit errors for requests from the Translate by Zapier integration. This is causing approximately 88% of translation requests to fail. We have confirmed that this issue originates from Google's API, not from Zapier's systems.
Who's Affected
Affected users may see failed translation steps in their Zaps, though the errors are not automatically disabling workflows.
What We're Doing
Our engineering team is actively investigating mitigation options. We will provide updates as we make progress.
Next Update
We expect to have more information soon. We appreciate your patience as we work to resolve this issue.