Our Engineering team identified and resolved the issue causing degraded performance for Agents. Due to the nature of the issue, we're not able to replay Agent executions during the following incident windows
2026-06-18, between 5:47–7:15PM UTC
2026-06-18, between 8:32 PM–10:08 PM UTC
Affected users have been notified via email
The incident has been resolved, and Agents is now operating as expected.
Resolved
Our Engineering team identified and resolved the issue causing degraded performance for Agents. Due to the nature of the issue, we're not able to replay Agent executions during the following incident windows
2026-06-18, between 5:47–7:15PM UTC
2026-06-18, between 8:32 PM–10:08 PM UTC
Affected users have been notified via email
The incident has been resolved, and Agents is now operating as expected.
Investigating
We’re currently experiencing an issue where some Zapier Agents runs may fail or be missed.
This may affect:
Zapier Agents
Agent-triggered workflow runs
Zapier’s core automation systems are otherwise continuing to process normally.
If you need help, contact Support: https://zapier.com/app/get-help