We have successfully resolved the Facebook Lead Ads integration issue that affected our platform from 12:30pm–4:00pm PDT (7:30pm–11:00pm UTC) on June 16, 2026.
During this window, customers experienced failures when connecting or reconnecting Facebook Lead Ads and Facebook Pages integrations, and existing Zaps using these integrations failed to execute. We identified this as an upstream issue with Facebook's APIs, which has since been resolved.
All affected workflows have been replayed and are now operating normally. If you continue to experience any issues with your Facebook integrations, please try reconnecting your Facebook app connection or don't hesitate to contact Zapier Support: https://zapier.com/app/get-help.
No components marked as affected
Resolved
We have successfully resolved the Facebook Lead Ads integration issue that affected our platform from 12:30pm–4:00pm PDT (7:30pm–11:00pm UTC) on June 16, 2026.
During this window, customers experienced failures when connecting or reconnecting Facebook Lead Ads and Facebook Pages integrations, and existing Zaps using these integrations failed to execute. We identified this as an upstream issue with Facebook's APIs, which has since been resolved.
All affected workflows have been replayed and are now operating normally. If you continue to experience any issues with your Facebook integrations, please try reconnecting your Facebook app connection or don't hesitate to contact Zapier Support: https://zapier.com/app/get-help.
Monitoring
Our Engineering team has completed its initial investigation and is now working with Facebook to resolve the issue. Errors have decreased during our investigation, but we will continue to monitor for any spikes until we hear back from the Facebook team.
We will provide updates as soon as we have more information.
Investigating
We are receiving customer reports that Zap workflows using Facebook Lead Ads or Facebook Pages are returning the following error when Zap runs occur.
"An unknown error occurred."
Users are also unable to connect to existing or create new app connections, with those connections instantly expiring.
We're looking into the issue to identify its root cause.