Between June 9 and June 11, some webhook-triggered Zap runs experienced processing delays of up to 48 hours.
All delayed events have since been processed successfully, and no data was lost during this delay. We are implementing additional safeguards to prevent recurrence.
If you experience any ongoing issues, contact Support: https://zapier.com/app/get-help
Thank you for your patience.
Resolved
Between June 9 and June 11, some webhook-triggered Zap runs experienced processing delays of up to 48 hours.
All delayed events have since been processed successfully, and no data was lost during this delay. We are implementing additional safeguards to prevent recurrence.
If you experience any ongoing issues, contact Support: https://zapier.com/app/get-help
Thank you for your patience.
Identified
Some webhook-triggered Zap runs are experiencing processing delays. Our team is actively investigating the cause and working toward a resolution.