We can confirm that the Admin Center is now loading as expected, and the issue is now resolved. If you're still unable to load the page, you may need to reload the page and/or clear your browser's cookies and cache.
If you're experiencing any issues with this was not resolved by clearing browser cache and cookies, please reach out to our support team here: https://zapier.com/app/get-help
No components marked as affected
Resolved
We can confirm that the Admin Center is now loading as expected, and the issue is now resolved. If you're still unable to load the page, you may need to reload the page and/or clear your browser's cookies and cache.
If you're experiencing any issues with this was not resolved by clearing browser cache and cookies, please reach out to our support team here: https://zapier.com/app/get-help
Monitoring
A fix has been applied to the Admin Center, and we're now monitoring for any adverse effects.
We'll continue to keep the incident open until we can confirm normal operations for the Admin Center.
Investigating
Users are unable to access the Admin Center within Zapier settings. This controls access to SSO, SCIM, app connections, and other user management settings. The Admin Center page does not finish loading, but doesn't show an error otherwise
Our Engineering team has confirmed the issue and is working toward resolving the problem as soon as possible.