The issue preventing ownership transfer in Teams and Enterprise accounts has been resolved. Account ownership transfers can now be self-served by following this guide: https://help.zapier.com/hc/en-us/articles/17946190203789-How-to-transfer-ownership-of-your-Team-or-Enterprise-account
If you're experiencing any issues with this, please do reach out to our support team here: https://zapier.com/app/get-help
No components marked as affected
Resolved
The issue preventing ownership transfer in Teams and Enterprise accounts has been resolved. Account ownership transfers can now be self-served by following this guide: https://help.zapier.com/hc/en-us/articles/17946190203789-How-to-transfer-ownership-of-your-Team-or-Enterprise-account
If you're experiencing any issues with this, please do reach out to our support team here: https://zapier.com/app/get-help
Monitoring
A fix has been released, and we're now monitoring for any unexpected issues due to the fix being released. We'll continue to monitor until we're confident the issue has been resolved.
Identified
Users have reported that transferring ownership between Team members returns the following error.
Unable to verify identity. Please try again.
Our Engineering team is looking into the issue and working to identify the root cause. We'll continue to update you as we have more information.