The issue affecting invoice access and downloads has been resolved. Service was fully restored at 18:30 UTC on April 27, 2026.
At 17:20 UTC an outage from the Databricks App caused invoices to fail to load or download from the Billing and Invoices Page. Databricks released a fix for their outage and invoices are functioning as normal. If you attempted to view or download any invoices during this time, you can retry that action now.
We apologize for the inconvenience this caused and appreciate your patience while the issue was resolved.
If you have any questions, please reach out to our Support Team - https://zapier.com/app/get-help
Resolved
The issue affecting invoice access and downloads has been resolved. Service was fully restored at 18:30 UTC on April 27, 2026.
At 17:20 UTC an outage from the Databricks App caused invoices to fail to load or download from the Billing and Invoices Page. Databricks released a fix for their outage and invoices are functioning as normal. If you attempted to view or download any invoices during this time, you can retry that action now.
We apologize for the inconvenience this caused and appreciate your patience while the issue was resolved.
If you have any questions, please reach out to our Support Team - https://zapier.com/app/get-help
Monitoring
Databricks has released a fix that has resolved the upstream issue causing users to not be able to access invoices. The billing and invoices page is working again, allowing invoices to be viewed and downloaded again.
We will continue to monitor the situation and provide any more details as they arise.
If you have any questions, please reach out to our Support Team - https://zapier.com/app/get-help
Investigating
We're currently investigating an issue where loading upcoming invoices on the billing page can return errors (HTTP 500) instead of showing invoice details.
We will update the page as soon as we have more information.
If you have any questions, please reach out to our Support Team - https://zapier.com/app/get-help