The issue causing 404 errors when editing and deleting Zap templates has been resolved.
Users attempting to edit templates were encountering 404 errors due to a routing misconfiguration introduced during an ATC (Application Traffic Control) rollout, which changed the default ATC origin from the monolith to the marketing site. This broke routing for the /zap-templates path, causing edit actions to fail.
The fix was deployed by completing the ATC routing correction to production. Once the rollout completed, edit functionality was restored. A remaining cosmetic bug — where the UI incorrectly indicates a template deletion failed despite the deletion succeeding — has been identified as a separate, no-impact bug and does not affect actual data.
No data was lost as a result of this incident.
If you're still experiencing issues, please contact Support by clicking above or visit: https://zapier.com/app/get-help
Thank you for your patience.
No components marked as affected
Resolved
The issue causing 404 errors when editing and deleting Zap templates has been resolved.
Users attempting to edit templates were encountering 404 errors due to a routing misconfiguration introduced during an ATC (Application Traffic Control) rollout, which changed the default ATC origin from the monolith to the marketing site. This broke routing for the /zap-templates path, causing edit actions to fail.
The fix was deployed by completing the ATC routing correction to production. Once the rollout completed, edit functionality was restored. A remaining cosmetic bug — where the UI incorrectly indicates a template deletion failed despite the deletion succeeding — has been identified as a separate, no-impact bug and does not affect actual data.
No data was lost as a result of this incident.
If you're still experiencing issues, please contact Support by clicking above or visit: https://zapier.com/app/get-help
Thank you for your patience.
Investigating
We are currently investigating 404 errors while editing zap templates.
Our engineering team is actively investigating the root cause and exploring solutions. We'll update this status page as we make progress toward a resolution.
If you're experiencing issues or need assistance, please contact our support team at https://zapier.com/app/get-help