Contact Support
Subscribe to updates
Contact Support
Subscribe to updates
Powered by
Privacy policy
·
Terms of service
Update PostgreSQL from version 14 to 17.
Resolved
·
Degraded performance
resolved
Sat, Apr 4, 2026, 04:16 PM
(
7
hours ago)
·
View all updates
Affected components
Apr 4, 2026, 04:13 PM
04:16 PM
Beta Products
1 affected component
Updates
Resolved
resolved
Sat, Apr 4, 2026, 04:16 PM
Monitoring
No customer impact identified
Sat, Apr 4, 2026, 04:13 PM
Update PostgreSQL from version 14 to 17. - Zapier Status