We’ve resolved the issue causing intermittent Internal Server Errors (HTTP 500) for some Enterprise customers when editing Zaps that use app approvals.
Our teams implemented a fix and confirmed recovery. If you continue to experience issues editing affected Zaps, please contact support. https://zapier.com/app/get-help
Resolved
We’ve resolved the issue causing intermittent Internal Server Errors (HTTP 500) for some Enterprise customers when editing Zaps that use app approvals.
Our teams implemented a fix and confirmed recovery. If you continue to experience issues editing affected Zaps, please contact support. https://zapier.com/app/get-help
Monitoring
We’ve implemented a fix for the intermittent Internal Server Errors (HTTP 500) affecting some Enterprise customers when editing Zaps that use app approvals.
We’re now monitoring the situation closely to confirm the issue is fully resolved and will share another update if we see any further impact.
If you have any questions, reach out to our Support team - https://zapier.com/app/get-help
Identified
We’ve identified the cause of intermittent Internal Server Errors (HTTP 500) affecting some Enterprise customers when editing Zaps that use app approvals. This can prevent changes from being saved during editing.
Our investigation indicates the errors occur when the Zap editor attempts to retrieve approval rules from our approvals service.
Our engineering teams are actively working to restore full reliability. Next update within 30 minutes, or sooner if we have a mitigation.
Investigating
We are currently investigating intermittent Internal Server Errors (HTTP 500) affecting Zaps. Some customers may experience errors when editing their Zaps, and we understand how disruptive this is to your workflows.
Our engineering teams are actively working to identify and resolve the root cause.
We will provide updates as we learn more. Thank you for your patience.